Не могу запустить на CPAN оболочки

При попытке запустить на CPAN я получаю:

Нельзя использовать неопределенное значение как символ ссылки в /usr/доли/Перл/5.12/архива CPAN.линия ТЧ 508.

В чем может быть проблема?

+247
Don in Atlanta 19 мар. 2010 г., 15:20:14
36 ответов

Я также столкнулся с этой проблемой.

Самое простое решение для этого-это подключить модем ZTE к ПК/ноутбук, когда он выключен. Затем запустите ваш ПК/ноутбук и он не будет висеть.

Но если оно опять зависает после и заново перезагрузите ваш ПК/ноутбук и используйте описанный выше метод.

Есть еще одно решение, вы можете попробовать как описано в этой теме, здесь -> Убунту зависает после переключения модема

+959
user3277375 03 февр. '09 в 4:24

Я пытаюсь установить ocatve 3.4 под Ubuntu 10.04 уметь работать в Eclipse. Я перешел по ссылке , Как установить последнюю Октаву , у меня есть выход:

~$ судо apt-получить установку октавы-3.4.3-64-немного
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
октавы-3.4.3-64-бит-это уже новейшая версия.
Следующие пакеты были установлены автоматически и больше не требуется:
 в Python-библиотек matplotlib-данные TTF-LyX по питон-ТЗ питона, когда pyparsing
Воспользоваться 'apt-получить autoremove', чтобы удалить их.
0 обновлено, 0 установлено новых, 0 для удаления, и 0 пакетов не обновлено.

когда я пытаюсь запустить октавы у меня:

~$ октавы
Программа 'Октава' может быть найдено в следующих пакетах:
 * octave3.0
 * octave3.2
Попробовать команду: sudo apt-получить установку <выбранный пакет>

Я не уверен, что я должен делать, я там нашел http://wiki.octave.org/Octave_for_GNU/Linux что 3.4.3-последняя версия для Ubuntu 10.04. Я не уверен, если я должен удалить все пакеты, или какому-то пути или делать это по-разному. Спасибо за помощь

+905
user563561 12 окт. 2012 г., 21:22:46
Другие ответы

Связанные вопросы


Похожие вопросы

Когда я запускаю команду sudo apt-получить установку -ф , я получаю этот выход:

Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Следующий пакет был установлен автоматически и больше не требуется:
libedbus1
Воспользоваться 'apt-получить autoremove', чтобы удалить их.
0 обновлено, 0 установлено новых, 0 для удаления, и 0 пакетов не обновлено.
Вт: дублирующие источники.список записей http://extras.ubuntu.com/ubuntu/ точный/главная пакеты для amd64 (в/var/lib в/АПТ/списки/дополнения.Убунту.com_ubuntu_dists_precise_main_binary-amd64_Packages)
Вт: дублирующие источники.список записей http://extras.ubuntu.com/ubuntu/ точный/главная пакеты для i386 (в/var/lib в/АПТ/списки/дополнения.Убунту.com_ubuntu_dists_precise_main_binary-i386_Packages)
Вт: Вы можете запустить apt-получить обновление, чтобы устранить эти проблемы

Как я могу исправить эти предупреждения?

+897
user291697 11 июн. 2014 г., 6:37:16

Я искал и нашел в этом у него есть некоторые обходные пути, как включение параметра "переопределение списка программного рендеринга" в хром://флаги/ некоторые говорят, что это работает, но это не гарантировано, может быть стоит попробовать.

+892
Paul Kilgour 2 янв. 2017 г., 21:36:14

Каждая файловая система имеет свои пределы, и Ext2/Ext3, но был ограничен 2 ТБ, но в ext4 имеет гораздо более высокий предел (что вы не достигнете в ближайшее время). Итак, используйте ext4, и вы должны быть в безопасности...

Для общих ресурсов NFS я думаю, что это зависит от того, даемон NFS/версию вы используете (проверьте в инструкции) и некоторых, конечно, есть предел размера файла. Для самбы это не должно быть проблемой, за исключением старых версиях Windows возможно?

+890
nu123 14 авг. 2015 г., 11:14:47

Я пробовал добавлять параметр noacpi и он успешно загрузился с LiveCD / LiveUSB в

+871
ignite 28 июл. 2013 г., 4:04:36

Длится поддержки Банши.ФМ для iPod скробблинг ? Rhytmbox делает!

+839
Strong Mer 23 нояб. 2016 г., 4:23:24

Я застрял с той же проблемой, в Ubuntu точные и x64 (Линукс Минт Майя на самом деле). Пустой экран, ничего больше. Я должен был ввести пароль для входа в систему и после система загружается, нажав Alt-F1 и открыт, по крайней мере, новой терминальной сессии. Поскольку интернет не работал (это в KDE, использует кошелек для хранения паролей, хотя вы могли бы теоретически представить слепо его пароль с логин), вместо того, чтобы установить последний файл xorg (согласно Октавия) Г просто сделал символическую ссылку:

судо ЛН-ы в /usr/lib32/ /УСР/Либ/

И перезагрузка. И это сработало.

+827
Roberto Bonano 27 апр. 2011 г., 18:02:54

Я установил индикатор-сеть на Maverick и он показывает только локальные сети с возможностью добавления DSL-соединение.Я через pppoeconf в настоящее время(может быть проблема).

+789
Russian people 11 окт. 2015 г., 6:54:36

Получается, ты ничего не должен делать - он просто работает.

Просто подключите телефон к компьютеру с помощью USB-соединения на Android установить на "диск". Настроить синхронизацию в Rythmbox, а затем синхронизировать.

Жаль, что я имел некоторый контроль над транскодирование, но по крайней мере они сжаты из FLAC в M4As по умолчанию.

+786
Bedeso Megerssoo 22 мар. 2015 г., 3:08:14

Я вижу пакет под названием "Linux" в Synaptic в 10.04, и я хочу знать, что происходит, когда я установить его, не делая мою систему в негодность. Это делает двойной загрузки вариант (у меня только Ubuntu), или заменить мое ядро?

+721
tcboy88 30 июн. 2013 г., 17:38:31

Значок был независим от установленных иконок, поэтому я думаю, что это приходит с Thunderbird или плагин для уведомления-меню. Это способ, чтобы начать искать его, но я не найти его.

+658
KodduX 27 дек. 2016 г., 17:32:44

(только ради делаю я также включил сюда Убунту нетбук издание)

Сходство между всеми версиями

  • Все версии поддерживают шифрование домашней папки.
  • Все варианты использовать те же приложения, репозитории, так что вы можете, например, установить веб-сервера и почтового сервера на Ubuntu Desktop или Ubuntu с рабочего стола на сервер Ubuntu или Ubuntu нетбук система (установка Убунту-десктоп пакет), а также любое другое сочетание.

Убунту Рабочего Стола

  • Установщик называется вездесущность, которая написана специально для того, чтобы быть графический инсталлятор для рабочего стола/живые компакт-диска.
  • Включает Wubi установщик для установки для Windows систем
  • Устанавливает базовую систему Ubuntu, в дополнение к Убунту-десктоп пакета и всех его зависимостей, в том числе GNOME и различных приложений, таких как Firefox и сопереживание.
  • Вы можете попробовать систему прямо с компакт-диска, и установка в графическом режиме.

Ubuntu Сервер

  • Установщик Debian для установки, основанный на тексте и совместно с Debian.
  • Это в принципе просто система базы Ubuntu, но при установке можно дополнительно установить такие услуги, как веб-или почтового сервера с помощью tasksel для.
  • Сервер Ubuntu не включает в себя графический пользовательский интерфейс, так что его никак не установить приложения, входящие в Убунту-десктоп пакет, например, GNOME.

Убунту Нетбук

  • Устанавливает базовую систему Ubuntu, в дополнение к Убунту-нетбук пакет и все его зависимости. Он также использует интерфейс Unity вместо интерфейса GNOME по умолчанию.
  • Метод установки очень похож на Ubuntu рабочего стола

Ubuntu с другого установщика

  • Установщик Debian для установки, основанный на тексте и совместно с Debian.
  • Альтернативный установщик установит Убунту-десктоп пакет, так как Ubuntu рабочего стола.
  • Он предназначен главным образом для установки или обновления Ubuntu на машинах, где это невозможно сделать другими способами. Например, мне пришлось использовать этот диск при установке Ubuntu на моей машине, потому что никто из все разновидности LiveCD будет работать.
  • Позволяет настройка LVM и LUKS зашифрованном файловых систем
  • Есть возможность установить "установить ОЕМ", которая позволяет установить ОС, но оставить персонализации, как имя пользователя и пароль в рамках первой загрузке.
  • Возможность установки с ltsp сервера.
+597
Alex177504 7 апр. 2016 г., 17:42:56

команда grep использует регулярные выражения, определенные в POSIX. По каким-то причинам в POSIX не определен в разделе.

У вас есть несколько альтернатив:

  • скажите grep, чтобы использовать регулярные выражения, определенные в Perl (Perl есть как вкладке):

    грэп -Р "\Т" foo.txt
    

    странице человек предупреждает, что это "экспериментальная" функция. по крайней мере, , кажется, работает нормально. но более продвинутые функции регулярные выражения в Perl не может.

  • использовать функции printf для печати табуляции для вас:

    команда grep "$(е '\т')" foo.txt
    
  • используйте литерал символа табуляции:

    грэп "вкладке^В<>" foo.txt
    

    то есть: типа грэп ", затем нажмите клавишу Ctrl и V, затем нажмите клавишу табуляции, а затем введите " foo.txt. нажав сочетание клавиш ctrl+v и в терминале вызывает следующий ключ следует принимать дословно. это означает, что терминал будет вставить символ табуляции вместо запуска какой-то функции, привязанные к клавишу Tab.

  • используйте ANSI с цитированием особенностью Баш:

    foo.txt команда grep $'\Т' 
    

    это не работает во всех оболочках.

  • использовать на awk:

    на awk '/\Т/'
    
  • использование СЭД:

    СЕПГ -н '/\т/п
    

Смотрите в Википедии статью о регулярных выражениях обзор определенными классами персонажей в POSIX и других систем.

+540
bitcoins4umy 26 февр. 2010 г., 4:32:47

Просто скрывает файл не мешаю никому доступа к ней. На обоих Ubuntu и Windows, скрытые файлы могут быть легко показаны в графическом файловый браузер и в командной строке. В Ubuntu, Наутилус файловый браузер покажет такие файлы, если вы идете в вид > Показывать скрытые файлы (или просто нажмите сочетание клавиш Ctrl+ч).

Если проблема заключается в том, что вы хотите, чтобы люди прочитав содержимое файла, даже если у них есть доступ к файлу (который включает если они украли ваш компьютер или жесткий диск), вы должны использовать шифрование; другие ответы здесь объяснить некоторые опции для этого.

Если проблема заключается в том, что файловой системе NTFS разделы монтируются в Ubuntu, так что все пользователи Ubuntu системы имеют полный доступ к ним, и вы хотите контролировать доступ к отдельным файлам и папкам на вашем Тома NTFS же, как они управляются в Windows, то, что вам нужно сделать, это смонтировать раздел NTFS с поддержкой разрешения NTFS.

Чтобы узнать, как это сделать, см. Этот ответ и настоящей документации. Это немного сложно, но вполне выполнимо. Если у вас возникли проблемы, не стесняйтесь задать вопрос с просьбой о помощи.

+522
antonkarpenko93 15 янв. 2015 г., 6:20:35

При использовании apt-получить установку <имя_пакета>и есть несколько зависимостей, которые должны быть загружены, терминал выводит имена дополнительных пакетов и общий размер, и запрашивает подтверждение перед загрузкой.

Но, если зависимости удовлетворены и ничего, кроме имени пакета должен быть загружен нет размер и никакого подтверждения.

Когда через Синаптик, я вижу общий размер, что новые пакеты, которые будут использовать после установки, но никак не увидеть размер, который должен быть загружен, кроме как перейти с пакета на пакет и используйте свойства, чтобы увидеть сжатый размер.

Я хотел бы знать, если есть способ, чтобы увидеть размер пакета(ов) в терминал и Синаптик перед загрузкой и установкой его/их?

+480
Tarun U 27 мар. 2013 г., 22:54:00

В случае, если пользователь хочет внести изменения в командной строке ядра, как бы я сделать так? Может я "кошка /proc/команду" просмотреть bootargs??

+470
hobbes66 24 нояб. 2015 г., 2:33:30

Мне нравится думать, что три разных вида пакетов:

  • Системные пакеты (пакеты или пакеты из приоритетных стандарт или выше)
  • Пользователь пакеты (вручную установленные пакеты приоритетных факультативной или дополнительной)
  • Зависимостей и рекомендует (автоматически установленные пакеты / все, что не система или пакет пользователя)

Показать все система "пакетов" вы можете использовать

поиск профпригодность '(~возможность соединения|~pimportant|~prequired|~е)'

Я хотел бы, чтобы все они установлены и отмечены как установленные вручную.

способность устанавливать '(~возможность соединения|~pimportant|~prequired|~е)!~я
что aptitude unmarkauto '(~возможность соединения|~pimportant|~prequired|~Е)~Я~м'

Чтобы показать все "пакеты пользователей" использовать

поиск профпригодность '~я!~М!(~возможность соединения|~pimportant|~prequired|~е)'

В этом списке должны быть только те пакеты, которые вы знаете, что вы хотите. Все другие пакеты, вероятно, просто зависимостей или рекомендует другие пакеты, вы можете отметить их как автоматически установленные

что aptitude markauto libsomething

Взгляните на профпригодность по поиска ссылку и
Что является необходимым, необходимых, важных, стандартный, опционные, или дополнительный пакет? в качестве справочной информации.

+465
COMP Superscalar 7 окт. 2017 г., 21:43:22

Мне жаль, но я не понимаю вопроса. Wubi-это альтернативный установщик Ubuntu через окна. Это wubi, это то, что он делает. Установить Ubuntu внутри Windows (не вместе). На самом деле это даже не обычной установки. В Ubuntu хранится под Windows файловая система NTFS.

В Ubuntu Wubi установщик и Wubi руководство для получения дополнительной информации.

Если вы хотите поменять загрузочную заказа, то вы должны использовать тщательно с Windows инструмент → Меню EasyBCD

Я настоятельно рекомендую установить Ubuntu параллельно с Windows = обычный двойной загрузки.

+447
Nanya 12 нояб. 2015 г., 2:58:18

Что бы это ни было, обновления 12.04 -> 12.10 Исправлена проблема.

+445
petwho 22 нояб. 2014 г., 23:33:33

Brscan3 загрузка и сканирование-ключ-инструмент здесь:

brscan3 32бит 0.2.11-4

brscan3 64бит 0.2.11-4

скан-ключ-инструмент 32бит 0.2.3-0

скан-ключ-инструмент 64бит 0.2.3-0

И следуйте инструкции по установке смотри здесь:

Драйвер сканера установить

Скан-ключ-инструмент установите

+439
K Nein 8 сент. 2015 г., 8:01:29

Это выглядит как один из вариантов сайт omgubuntu:

http://www.omgubuntu.co.uk/2012/07/gwoffice-integrates-google-docs-with-the-ubuntu-desktop

+416
Shan Khan 31 авг. 2011 г., 0:32:34

Временное решение это запуск программного обеспечения из командной строки с правами суперпользователя:

программного обеспечения-центр kdesudo 

Для устранения этой проблемы необходимо убедиться, что у вас все последние версии программного обеспечения, установленного.

судо apt-получить обновление && судо apt-получить обновление

Если проблема сохраняется, проверьте запуск приложения для проверки подлинности policykit теперь агент убедитесь, что он включен. Если это не доступно, вы должны добавить эту строку в запуске приложений:

с помощью polkit-кде-1

Похоже, это известная ошибка , что политики В комплект аутентификации агента не запускается.


Редактировать: как @gertvdijk упоминалось в комментариях, конечно вы должны убедится, что установлен агент policykit теперь это.

судо apt-получить установку с помощью polkit-кде-1

Еще запись запуска приложения-это бесполезно.

+314
Facsiga 3 янв. 2010 г., 23:13:57

Вопросы

1) есть сервер Ubuntu 12.04.2 ОС полностью совместима и поддерживает с бульдозером на базе AMD для Opteron 3280?

2) Обязательно ли использовать Ubuntu сертифицированных поставщиков серверного оборудования и моделей? Но у моего поставщика оборудования ( компания Fujitsu сервер PRIMERGY mx130 S2 с сервера) не в Ubuntu сервер сертифицированного оборудования список , это будет иметь какое-паника ядра ошибки или нестабильности системы в долгосрочной перспективе?

+304
Rabin Romman 12 мар. 2011 г., 0:41:24

Вот некоторые общие шаги по устранению неполадок для Intel беспроводной карт:

+285
ravenvii 20 апр. 2018 г., 13:31:25

Попробуйте установить индикатор частоты процессора:

суда apt-получить установку индикатора-подсистема cpufreq

Это позволит установить значок в appmenu, здесь можно нажать кнопку и переключить процессор на более консервативные настройки; посмотреть, если это помогает.

Если нет улучшения, может проверить этот ресурс:

https://wiki.ubuntu.com/Kernel/PowerManagement

Например, "индикатор погоды" является проблематичным, поскольку он постоянно пишет в лог-файл, останавливая диск становится полностью холостого хода в режиме энергосбережения, нагрев, включение вентиляторов и т. д. Об этом говорится в исследовании. Попробуйте найти приложения, которые делают это и удалить их.

Удачи.

+240
suhas bhairav 7 февр. 2016 г., 16:13:15

У меня есть две догадки. Во-первых, это может быть, что менеджер (программа в заряда графических эффектов) не освежающий районе, где анимация произошло после последнего кадра. У меня это случилось все время на моем рабочем столе. Что мне делать, чтобы избавиться от него, чтобы слегка переместить куб (наиболее подходящий графический эффект использует весь экран должен работать). Чтобы проверить это, вы могли бы войти, используя классический интерфейс в Ubuntu, а затем выполнить перевод --заменить. Если это не произойдет больше, это может быть он.

Другое дело, можно было бы быть некоторым перетащите ошибка. В этом случае, вы не могли нажать на кнопку, что за серая зона. К сожалению, я не уверен, что вы могли бы сделать о том, что кроме того, чтобы увидеть, если вы можете воспроизвести его, а затем сообщать об этом.

+234
dominique 7 дек. 2017 г., 7:49:04

Возможные Дубликаты:
Увеличение Размера Наценки На Окна

Используя тему атмосфера в сочетании с Compiz делает изменение для многих окнах практически невозможно без использования контекстного меню, а не почти все окна В изменить углу.

Какой самый лучший способ увеличить маржу окно до разумного значения?

+161
Cheesums 31 июл. 2013 г., 17:22:46

Короткий ответ: вашей ноутбуки имеют 64-битных процессоров.

Когда мы говорим о 64-битных, мы говорим о архитектуре x86-64. Это расширение семейства i686 , разработанное компанией AMD. Они так далее переименуйте его на платформах amd64 и с тех пор на миллиард больше, имена (в том числе: х64, архитектурой IA-32e и Интел 64) пришел в бытие... но все они означают одно и то же. (Боковая панель: с архитектурой IA-64 - это совершенно разные и имеет очень мало общего с архитектурой x86)

Повторить: х86-64 - это расширение. В нем есть все регистры процессора, что i686 в ЦП, но с лишние. В семейства i686 процессор имеет все эти для i586 процессора, с массовкой. То же повторяет вниз для i386. Цель этого "супер-настройки" регистров/инструкции для полной обратной совместимостью.

Чтобы перевести это из Geekish, 64-битных процессоров может работать все 32-разрядный процессор. Я подозреваю, что это то, что произошло с тобой и это где путаница возникла. Я подозреваю, что у вас 32-разрядные операционные системы установленные на ноутбуки до. 64-битный процессор более чем способны сделать это.

Но 32-разрядных процессоров не могут запустить 64-битный код. У них нет ни достаточного словарного запаса и способности для выполнения 64бит-компиляции команды.

Поэтому для того, чтобы ваш ноутбук работать на x86-64-компиляции программного обеспечения, они должны быть для x86-64 процессоров. Он просто не будет работать иначе.

Если вы не согласны, отредактировать ваш вопрос, чтобы включать марку и модель ноутбука, и я могу подтвердить аппаратные спецификации...

И для i386 стенды для "Intel 80386", как вы догадались.

+116
An0nym2035 27 нояб. 2019 г., 10:46:47

суда apt-получить установку пакета cryptsetup после использования диска-утилита для создания разделов на диске и сделать ее зашифрованной. У вас будут спрашивать пароль при вставке флэш-накопитель с тех пор

+93
Simantev14 22 апр. 2015 г., 10:59:08

Я думаю, что нечто подобное решения от 10.04 будет полезно:
Как добавить разные обои для разных рабочих областях, но как shellscript?

Также хороший ответ здесь:
Есть ли способ, чтобы иметь разные обои и различные лаунчеры/документов в разных рабочих областях? [закрыт]

Я согласен, эти комментарии и думаю, что это может быть реализовано путем создания, например, скрипт, эту команду плагин, или расширение для GNOME.
Много способов экспериментировать с эту команду , как анимация может быть использована, срабатывает от рабочей смены событий.

Ближе решение, описанное в ubuntuforums:
[Решено] разные обои для каждого рабочего стола в Ubuntu 11.10

В соответствии с Носатик параметры конфигурации существуют переменные:

own_window
Логическое, создать собственное окно для Носатик или нет

own_window_type
если own_window да, вы можете указать тип нормального, рабочего стола, док-панели или переопределить (по умолчанию: normal). Рабочего стола Windows-особые окна, которые не имеют оконных украшений; они всегда видны на вашем столе; не появляться в пейджер или на панели задач; и липкие во всех рабочих областях. Панели, окна, запас пространства вдоль края стола, как и панели и панели задач, предупреждения у распахнутого окна от перекрытия. Кромка подбирается в зависимости от параметра выравнивания. Переопределить окна не находятся под контролем оконного менеджера. Намеки игнорируются. Этот тип окна может быть полезна в определенных ситуациях.

Я думаю, да, носатый могут быть настроены для использования С эту команду.

+92
Arnoldo Lora 7 февр. 2010 г., 8:08:43

На этот раз я надеюсь, что я не права. Проверьте эту ссылку http://en.community.dell.com/support-forums/desktop/f/3514/p/19275503/19488540.aspx где кто-то пишет ваш аппарат поддерживает только 4 × 1ГБ = 4ГБ оперативной памяти

Возможно, в BIOS / прошивки требуется / имеется?

+44
user321627 9 окт. 2017 г., 20:31:09

Как узнать, сколько оперативной памяти на моем компьютере? Я с Ubuntu 13.04.

+44
Chaous 17 июл. 2010 г., 11:44:48

Я получаю сообщение об ошибке показано ниже. Я новичок в Ubuntu. Как я могу решить это?

> install.sh: 187: [: верно: неожиданный оператор
udevadm существует!
******Начните в /opt водитель/TATA_DOCOMO_3G/
это инсталляция драйвера Linux 
сделать -с /Либ/модули/3.2.0-45-универсальные ПАИ/построить M=/tmp/и ONDA_driver_install_V3.1.Модули 2 
сделать[1]: ввод каталога в/usr/src/и оригинальных заголовков-3.2.0-45-универсальный-Пае'
 Копия [м] в /tmp/ONDA_driver_install_V3.1.2/онда.о
в /tmp/ONDA_driver_install_V3.1.2/онда.с:18427:22: фатальная ошибка: на USB-WWAN-сети.ч: нет такого файла или каталога
компиляция прекращается.
сделать[2]: *** [/tmp/и ONDA_driver_install_V3.1.2/онда.о] Ошибка 1
сделать[1]: *** [_module_/tmp/и ONDA_driver_install_V3.1.2] Ошибка 2
сделать[1]: покидая каталога в/usr/src/и оригинальных заголовков-3.2.0-45-универсальный-Пае'
сделать: *** [модули] Ошибка 2
это настроенный ,версия ядра ядра: 3.2.0-45-универсальный-Пае
введите функцию customize_driver_install 
СР: Онде не может стат`.ко': нет такого файла или каталога
Фатальная ошибка: модуль Онды не найден.
disselfirefox.driver_install ПП.запустить Нм.ПП readme_onda.txt ЮВ конец /опт водителя/TATA_DOCOMO_3G/
install.sh: 426: [: верно: неожиданный оператор
установка завершена!!!
....После установки, вы найдете Тата Docomo в 3G в "приложения->интернет->Тата Docomo в сетях 3G". Нажмите на тата Docomo в 3G и приложение будет работать
install.sh: 434: чтение: незаконный вариант -Н
./TATA_DOCOMO_3G: ошибка при загрузке разделяемых библиотек: libqt-МТ.так.3: Невозможно открыть разделяемый объектный файл: нет такого файла или каталога
+33
JasonMelb 23 дек. 2013 г., 16:47:52

Нашел решение этой проблемы. Следующий будет заставить его починить самому

судо компании VMware-modconfig --консоли --установить-все
+32
Kye R 23 апр. 2019 г., 0:25:03

Я установил в Bugzilla 4.0. Это работает, однако, я не могу использовать функцию для отправки с SMTP с uthentication.

Согласно примечания к выпуску, если установить: подлинность::SASL аутентификации для SMTP::данные должны быть доступны в Почте упасть.

работает ./checksetup --проверка-модули:

Проверка модулей Perl...
Проверки на ЦГИ.ПМ (В3.51) ОК: найдено В3.52 
Проверка дайджест-ша (любой) ОК: нашли У5.47 
Проверка на команду timedate (версия V2.21) ОК: нашли П2.23 
Проверка Датавремя (версии v0.28) ОК: нашли в v0.70 
Проверка даты и времени-часовой пояс (версии v0.71) ОК: найдено В1.38 
Проверка дБи (В1.41) ОК: найдено В1.609 
Проверка шаблона-инструментарий (версия V2.22) ОК: нашли П2.22 
Проверка по электронной почте-отправить (версия V2.00) ОК: нашли П2.198 
Проверка электронной почты-МИМ (В1.904) ОК: найдено В1.910 
Проверка Ури (любой) ОК: найдено В1.52 
Проверка на список-MoreUtils (версии v0.22) ОК: нашли в v0.33 

Проверив имеющиеся модули Perl ДБР...
Проверка по DBD-ПГ (В1.45) не найдено 
Проверка по DBD-MySQL-сервера (В4.00) ОК: нашли В4.012 
Проверка по DBD-Оракул (версии v1.19) не найден 

Следующие модули Perl являются обязательными:
Проверка на ГД (В1.20) ОК: нашли П2.39 
Проверка на графику (версии v2.1) ОК: нашли П2.4.1 
Проверка шаблона-ГД (любой) ОК: найдено В1.56 
Проверка GDTextUtil (любой) ОК: нашли в v0.86 
Проверка GDGraph (любой) ОК: найдено В1.44 
Проверка для XML-веточка (любая) ОК: найдено В3.32 
Проверка МИМ-инструменты (У5.406) ОК: нашли У5.502 
Проверка libwww-perl версии (любой) ОК: нашли У5.834 
Проверка PatchReader (версии v0.9.4) ОК: нашли в v0.9.6 
Проверка для Perl-LDAP (с любой) ОК: нашли в v0.43 
Проверка на подлинность-протокол SASL (любой) ОК: нашли П2.15 
Проверка RadiusPerl (любой) ОК: нашли в v0.20 
Проверка мыла-лайт (версия v0.712) ОК: нашли в v0.714 
Проверка для JSON-RPC в (любой) ОК: нашли в v0.96 
Проверка для JSON-хз (версия V2.0) ОК: нашли П2.32 
Проверка за проверкой-зараза (любой) ОК: найдено В1.04 
Проверка для HTML-парсера (В3.40) ок: найдено В3.64 
Проверка для HTML-скруббер (любой) ОК: нашли в v0.09 
Проверка по электронной почте-МИМ-привязанность-стриптизерша (любой) ОК: найдено В1.316 
Проверка по электронной почте-ответ (любой) ОК: найдено В1.202 
Проверка TheSchwartz (любой) ОК: найдено В1.10 
Проверка Демон-универсальный (любое) ОК: нашли в v0.81 
Проверка под mod_perl (В1.999022) ОК: нашли П2.000004 
Проверка для Apache-потребления sizelimit (версии v0.93) ОК: нашли в v0.95 
Проверка по математике-случайные-Безопасный (версии v0.05) ок: нашли в v0.06 
Предупреждение: Мы не могли проверить в конфигурации Apache. Это иногда
происходит, когда вы не работаете checksetup.pl как корень. Чтобы увидеть
проблема, с которой мы столкнулись, выполнить: выполнить /sbin/apache2 не -т -д DUMP_MODULES

модуль устанавливается

Проверка на подлинность-протокол SASL (любой) ОК: нашли П2.15

Однако, в Параметры->Почта - я не вижу протокола SMTP:данные имеются.

Я установил также следующее:

судо apt-получить установку либнет-ssleay-на Perl
судо apt-получить установку libcrypt-ssleay-на Perl

а также:

На CPAN: установите net::SMTP с::СС

Я не думаю, что любые изменения кода, необходимого для того, чтобы это работало, но кто знает.

По данным м/с https://serverfault.com/questions/83113/bugzilla-mail-delivery-method-using-tls-for-gmail Я добавил строку

использование электронной почты::отправить::СМТП::ТЛС;

Мейлера.файл личку. Что вызвало проблему

Ошибки программного обеспечения:

> Не могу найти адрес электронной почты/отправить/СМТП/ТЛС.ПМ в @Inc (@Inc, в содержит: .
> сайт lib/i686 в-линукс-гну-нить-мульти Либ в /etc/Перл
> /usr/местные/библиотека/язык Perl/5.10.1 /usr/местные/доли/на Perl/5.10.1 /УСР/Либ/perl5
> /usr/доли/perl5 /УСР/Либ/Перл/5.10 /usr/доли/Перл/5.10
> /usr/местные/библиотека lib/site_perl) на багтрекер/почтовик.линия часов 48. Начать
> не удалось--компиляция прервана на багтрекер/почтовик.линия часов 48. Сборник
> не требуют в багтрекер/авт.линия часов 35. Начать
> не удалось--компиляция прервана на багтрекер/авт.линия часов 35. Сборник
> не требуют в багтрекер.линия часов 40. Начать не удалось--компиляция
> прервать в багтрекер.линия часов 40. Компиляции не требуют в
> в /var/www в/багтрекер/editparams.линии цги 28. Начать не удалось--компиляция
> прервана в файле /var/www в/багтрекер/editparams.линии цги 28. Для помогите, пожалуйста
> отправлять почту к админу (админу@localhost в), выдавая эту ошибку
> сообщение и дата и время ошибки.

Посоветуйте, пожалуйста.

*отметить, что вчера у меня было ощущение, что меня нет в Bugzilla 4.0 установлен :-) в любом случае, я проверил, и это 4. enter image description here

+28
Joshua Waring 2 окт. 2016 г., 8:36:06

Показать вопросы с тегом